Диаграмма Ганта и графическая схема сторонними средствами

Публикация № 935007

Разработка - Практика программирования

Обработка гантт диаграмма гантта amCharts амчартс графическая схема js raphael мобильный клиент работа с html гант ганта.

Примеры формирования диаграммы Ганта и графической схемы в 1С сторонними средствами.

Недавно возникла необходимость формировать отчеты на мобильных устройствах. Для реализации идеи решили попробовать мобильный клиент.
С обычными отчетами проблем не возникло, но были два отчета, которые "не смогли".
Один из них - Диаграмма Гантта, другой - построен при помощи Географической схемы. Эти типы не имеют отображения на мобильном клиенте.

Было решено попробовать вывести данные отчетов в поле html.


Диаграмма Гантта.

Самым простым способом показалось использовать amCharts. Спасибо публикации за примеры работы с библиотеками. 
 

В обработке подготовлен шаблон html, который всего лишь нужно дополнить выводимыми данными.
Формируем таблицу данных:
 

Функция ПолучитьДанные()
	
	Данные = Новый ТаблицаЗначений;
	
	Данные.Колонки.Добавить("category");
	Данные.Колонки.Добавить("segments");
	
	ТаблицаСегментов = Новый ТаблицаЗначений;
	ТаблицаСегментов.Колонки.Добавить("start");
	ТаблицаСегментов.Колонки.Добавить("end");
	ТаблицаСегментов.Колонки.Добавить("color");
	ТаблицаСегментов.Колонки.Добавить("task");
	
	НоваяСтрока = Данные.Добавить();
	НоваяСтрока.category = "Авиа";
	ТаблицаСегментов.Очистить();
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-01-01";
	НоваяСтрокаСегментов.end = "2016-01-14";
	НоваяСтрокаСегментов.color = "#b9783f";
	НоваяСтрокаСегментов.task = "Gathering requirements";
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-02-01";
	НоваяСтрокаСегментов.end = "2016-02-14";
	НоваяСтрокаСегментов.color = "#b9783f";
	НоваяСтрокаСегментов.task = "Gathering requirements";
	
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрока = Данные.Добавить();
	НоваяСтрока.category = "Прокат";
	
	ТаблицаСегментов = Новый ТаблицаЗначений;
	ТаблицаСегментов.Колонки.Добавить("start");
	ТаблицаСегментов.Колонки.Добавить("end");
	ТаблицаСегментов.Колонки.Добавить("color");
	ТаблицаСегментов.Колонки.Добавить("task");
	ТаблицаСегментов.Очистить();
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-01-02";
	НоваяСтрокаСегментов.end = "2016-01-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-02-02";
	НоваяСтрокаСегментов.end = "2016-02-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-03-02";
	НоваяСтрокаСегментов.end = "2016-03-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	Возврат Данные;
	
КонецФункции

Далее таблица преобразуется в строку и передается в шаблон.

В итоге получаем: 

 

Графическая схема.

В свое время возникла необходимость графически отображать цепочки продаж.

При анализе различных способов была найдена публикация, которая и помогла реализовать такой отчет.

При решении текущей задачи вспомнилась работа с графикой на js при помощи библиотеки raphael.
В итоге все свелось просто к рисованию фигур по точкам. Точки брались прямо из графической схемы:
 

Процедура ЗаполнитьПример()
	
	СписокИдентификаторов.Очистить();
	Уровень1 = ДеревоОбъектов.ПолучитьЭлементы();
	Уровень1.Очистить();
	
	ГрафСхемаXDTO=СериализаторXDTO.ЗаписатьXDTO(ГрафСхема);
	
	Для Каждого ОбъектГС Из ГрафСхемаXDTO.Item Цикл
		
		Если ОбъектГС.itemtype = 9 Тогда
			
			НовСтр = Уровень1.Добавить();
			
			ТочкиСтрокой = "";
			
			Для Каждого Точка Из ОбъектГС.point Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ?(ПустаяСтрока(ТочкиСтрокой), "", ", ") + СтрЗаменить(Строка(Точка.x), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, "");
				
			КонецЦикла;
			
			НовСтр.Шейп = ТочкиСтрокой;
			НовСтр.Цвет = "#ffa0e0";
			НовСтр.Описание = ОбъектГС.itemCode;
			НовСтр.Описание_Точка = "0, 0";
			СписокИдентификаторов.Добавить(НовСтр.ПолучитьИдентификатор());
			
		ИначеЕсли ОбъектГС.itemtype = 1 Тогда
			
			НовСтр = Уровень1.Добавить();
			
			ТочкиСтрокой = "";
			
			МассивТочек = Новый Массив;
			
			Для Каждого Точка Из ОбъектГС.point Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ?(ПустаяСтрока(ТочкиСтрокой), "", ", ") + СтрЗаменить(Строка(Точка.x), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, "");
				МассивТочек.Добавить(СтрЗаменить(Строка(Точка.x + 1), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, ""));
				
			КонецЦикла;
			
			Сч = МассивТочек.Количество() - 1;
			Пока Сч >= 0 Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ", " + МассивТочек[Сч];
				
				Сч = Сч - 1;
				
			КонецЦикла;
			
			НовСтр.Шейп = ТочкиСтрокой;
			НовСтр.Цвет = "#999999";
			НовСтр.Описание = "";
			НовСтр.Описание_Точка = "0, 0";
			НовСтр.Линия = Истина;
			СписокИдентификаторов.Добавить(НовСтр.ПолучитьИдентификатор());
			
		КонецЕсли;
		
	КонецЦикла;	
	
КонецПроцедуры

В итоге получаем:

Стрелочки рисовать уже не стал. Но, при желании, это можно сделать.

 

Обе обработки делались на платформе 8.3.11.2867

Тестировалось на конфигурации Управление нашей фирмой, редакция 1.6 (1.6.13.60), но должно работать на любой другой конфигурации под управляемыми формами. 

Скачать файлы

Наименование Файл Версия Размер
Диаграмма Гантта в html:
.epf 93,68Kb
01.11.18
5
.epf 1.0.0 93,68Kb 5 Скачать
Графическая схема в html
.epf 45,95Kb
01.11.18
0
.epf 1.0.0 45,95Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. 1segen1 32 02.11.18 08:05 Сейчас в теме
Не знал, что название диаграммы уже пишется по-другому (Гантт).
2. no_betrayal 26 02.11.18 11:18 Сейчас в теме
(1)Взято с Вики. Да и в амЧартс в английском варианте gantt. Хотя СП считает иначе)
3. user5300 473 06.02.20 08:52 Сейчас в теме
Как убрать гиперссылку "Js chart by amCharts" ?
4. no_betrayal 26 06.02.20 14:29 Сейчас в теме
(3)Эта ссылка - условие бесплатного использования библиотеки.

Но если очень сильно хочется заморочиться - можно сделать следующее:

1. Заменить процедуру в форме:
Процедура СформироватьГанттаНаСервере()
	
	Данные = ПолучитьДанные();
	
	ДанныеСтрокой = AmChartsДанные(Данные);
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	
	//Шаблон = ОбработкаОбъект.ПолучитьМакет("Шаблон").ПолучитьТекст();
	Шаблон = ОбработкаОбъект.ПолучитьМакет("Макет").ПолучитьТекст();
	amcharts = ОбработкаОбъект.ПолучитьМакет("amcharts").ПолучитьТекст();
	serial = ОбработкаОбъект.ПолучитьМакет("serial").ПолучитьТекст();
	light = ОбработкаОбъект.ПолучитьМакет("light").ПолучитьТекст();
	gantt = ОбработкаОбъект.ПолучитьМакет("gantt").ПолучитьТекст();
	
	Текст = СтрЗаменить(Шаблон, "&amcharts.js", amcharts);
	Текст = СтрЗаменить(Текст, "&serial.js", serial);
	Текст = СтрЗаменить(Текст, "&light.js", light);
	Текст = СтрЗаменить(Текст, "&gantt.js", gantt);
	
	ПолеХТМЛ = СтрЗаменить(Текст, "&DataProvider", " [ " + ДанныеСтрокой + " ] ");
	
КонецПроцедуры
Показать


Так перейдем на использование скриптом из шаблонов.
2. В шаблоне "amcharts" найти неугодную фразу и заменить, например, на пустую строку.

Но я настоятельно рекомендую в таком случае перенести ссылку хотя бы на форму, чтобы не нарушать пользовательское соглашение.
user5300; +1 Ответить
5. user5300 473 06.02.20 15:17 Сейчас в теме
(4) можно оставить на форме но скрыть видимость ))
и еще такой вопрос, можно ли добавить текст в шкалу времени (или рядом)
и можно ли отобразить числа месяца ?
6. no_betrayal 26 06.02.20 16:36 Сейчас в теме
(5)Если текст нужен под шкалу времени, в макете шаблона можно попробовать добавить еще один div элемент с текстом.

и можно ли отобразить числа месяца ?


Дата нужна в формате 06.02, а не фев 02?

Сейчас точно не подскажу, как сделать. Нужно курить документацию:
https://docs.amcharts.com/3/javascriptcharts/AmCharts


Я обычно открывал демку диаграммы https://www.amcharts.com/demos-v3/gantt-chart-dates-v3/
Там есть возможность перейти в редактор
"Open in:"
Я использую codepen.
Там можно поэкспериментировать с параметрами и прочим.

Но на скорую руку сделать не получилось.

У меня использована версия 3, в версии 4 сильно больше настроек для шкалы времени.
user5300; +1 Ответить
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    28413    9    tormozit    44    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    13037    17    sapervodichka    41    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    24714    13    HostHost    40    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    15550    11    Dementor    29    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    16520    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    18598    20    Stepa86    44    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    28933    13    vasilev2015    57    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    23831    74    Evil Beaver    117    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    25076    19    Hatson    22    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    20037    0    YPermitin    89    

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Универсальные обработки Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    24584    85    Synoecium    46    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    26683    86    m-rv    57    

Отладка сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    23229    83    maxx    58    

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Практика программирования v8 1cv8.cf Абонемент ($m)

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    19899    15    dmitry1975    32    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    36864    17    kalyaka    16    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    68721    23    dsdred    24    

Жизненный цикл управляемой формы. Шпаргалка разработчика

Практика программирования Математика и алгоритмы v8::УФ 1cv8.cf Абонемент ($m)

Прочитав когда-то давно книжку "Разработка управляемых форм", составил для себя такую схемку-напоминалку для обращения в процессе разработки. С тех пор не раз выручала и избавляла от необходимости лезть в гуглы.

1 стартмани

29.06.2018    28037    51    stas_ganiev    26    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    26438    11    SITR-utyos    13    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    24156    19    mvxyz    17    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    39561    33    dsdred    36    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    39618    83    kalyaka    34    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    32057    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    34547    27    agent00mouse    0    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    83050    292    Dementor    44    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24006    49    kwazi    6    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    23818    61    vasvl123    9    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    50844    62    dewersia    32    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    27855    125    PLAstic    52    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    87703    121    json    27    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    17207    12    RocKeR_13    16    

Интеграция сценарного тестирования в процесс разработки

Практика программирования Инструментарий разработчика v8::УФ Абонемент ($m)

Эта статья является практическим пособием по внедрению тестирования на основе сценариев в процесс разработки программного обеспечения на базе платформы 1С:Предприятие 8.3. Документ отличает прикладная направленность, в нем содержится много кода, подходов и конкретики. Все рассмотренные примеры основаны на использовании бесплатной конфигурации Тестер

1 стартмани

04.07.2017    28415    24    grumagargler    30    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    111589    13    signum2009    45    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    45961    15    DarkAn    86    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    24482    8    wowik    3    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    27720    110    romasna    49    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    19404    95    Alxby    17    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    18588    90    igel9780    21    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции Промо

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    24209    25    informa1555    26    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    135112    921    json    65    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    33390    95    json    25    

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример Промо

Практика программирования Универсальные функции v8::УФ 1cv8.cf Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    51539    60    rpgshnik    26    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    43912    36    Demanoidos    60